1. Delete package-lock.json file from your project, if it is created.
  2. Check your npm version using npm -v
  3. If your npm version is 5 and above. Then run the following command:
  4. npm cache verify
  5. Then run your install command npm install -g @ionic/cli